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Viktigt 
 

 

Laborationen kräver att man är ordentligt förberedd, 

annars kan man inte genomföra den. Därför gäller följande: 

 

Det är viktigt att ha läst igenom lab-anvisningen i förväg, 

samt att man jobbat med förberedelseuppgifterna. (Du 

behöver naturligtvis inte kunna detaljer om 

laborationsuppgifterna.) 

 

Förutom lab-anvisningen ska följande avsnitt i 

kurskompendiet ”Teknisk Fotografi” studeras (behövs bl.a. 

för att lösa förberedelseuppgifterna) 

 
 Kap. 6.1 (Optisk avbildning) 
 Kap. 24.1-24.4 (Färglära) 
 Kap. 38 (Sampling) 

 

 

Laborationen börjar utan akademisk kvart. 
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Laborationens syfte och innehåll 
 
Ett syfte med denna laboration är att undersöka hur samplingtätheten påverkar resultatet 
vid bildregistrering. Målet är att både kunna uttrycka resultaten kvantitativt, samt att få en 
inblick i de felaktigheter som kan uppstå på grund av sampling. Ett annat syfte med 
laborationen är att studera och kvantifiera färginformationen i bilder. Färgbilder uppdelas 
i RGB-komponenter, ur vilka färgkoordinater beräknas och presenteras i en färgtriangel. 
Färginformationen används också för att utvinna kvantitativ bildinformation, t.ex. 
arealen av åkerfält med en viss gröda. 
 
 

Utrustning 
 
I dag erhålls bilder oftast som filer direkt från en digitalkamera. Om materialet istället 
utgörs av klassiska fotografiska bilder, kan dessa scannas in med dokumentscanner 
(pappersbilder) eller filmscanner (negativ- eller diafilm). För en beskrivning av hur en 
dokumentscanner fungerar hänvisas till website http://www.howstuffworks.com (sök på 
”flatbed scanner”).  
 

I denna laboration har allt bildmaterial redan lagts in som färdiga filer på datorns 
hårddisk. Samma datorutrustning (PC) och programvara (ImageJ och Datascape) som vid 
tidigare laborationer används.  
 
 

Samplingtäthet 
 
I laborationen utgår man från en digital bild av ett svartvitt linjemönster med hög 
pixeltäthet. Detta mönster omsamplas för att studera effekten av låga pixeltätheter. Enligt 
teorin (kap. 38 i kompendiet) måste samplingtätheten vara drygt dubbelt så hög som 
mönstertätheten man vill registrera. Vid laborationen undersöks hur väl denna regel 
fungerar i praktiken, och vad som händer om den inte uppfylls. 
 
 

Färganalys 
 
Som beskrivs i kompendiet Teknisk Fotografi så kan olika färger beskrivas som en 
blandning av rött (R), grönt (G) och blått (B). Detta kallas additiv färgsyntes. Exempelvis 
uppfattar vi en blandning av R och G (men inget B) som en mättad gul färg. Detta 
innebär att man kan beskriva olika färger som positioner i en tredimensionell rymd, där 
x-, y- och z-koordinaterna representerar mängden R, G och B som vi ska blanda för att 
få den aktuella färgen. Vid närmare eftertanke inser man dock att positionen i RGB-
rymden ger oss information både om färgton och intensitet (ljushet). 
 
Exempelvis motsvarar punkten RGB = (100, 40, 80) i färgrymden precis samma färgton 
och mättnad som (50, 20, 40), eftersom förhållandet mellan de tre färgkomponenterna är 
detsamma (5:2:4). Den första punkten i färgrymden svarar emellertid mot en högre 
ljusintensitet. Intensiteten är oviktig när man gör färganalys, och därför vill man att alla 
bildpunkter som har samma färgton och mättnad ska beskrivas av samma punkt i 
färgrymden. Detta åstadkommer vi genom att normera RGB-koordinaterna. De nya 
normerade koordinaterna, som vi ska beteckna med r, g och b, erhålls ur 
 

http://www.howstuffworks.com/
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r, g och b, ligger i intervallet 0 till 1 och spänner upp ett plan enligt Fig. 1. Eftersom vi 

vet att r + g + b = 1, så finns all information i en projektion i rg-planet (vi vet ju att b = 

1 – r – g). En sådan projektion visas i Fig. 2, och motsvarar att vi tittar uppifrån och ner 

längs b-axeln i Fig. 1. Olika varianter på den ”färgtriangel” som visas i Fig. 2 används i 
många sammanhang som inbegriper färglära. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 
Varje pixel i en digital bild kan på detta sätt tilldelas en position i färgtriangeln beroende 
på vilken färgton och mättnad den har. Detta är precis vad vi ska göra i denna laboration. 
 
För att analysera en färgbild måste man dela upp den i RGB-komponenter. Detta innebär 
att man från en färgbild får tre svartvita bilder, R-bild, G-bild och B-bild. Pixelvärdena i 
R-bilden ger oss information om hur stor rödkomponenten är för pixlarna i den 
ursprungliga färgbilden. Motsvarande grön- och blåinformation får vi ur G- och R-

bilderna. För att räkna fram normerade färgkoordinater, r, g och b enligt Ekv. 1, för 
varje pixel i färgbilden måste man räkna fram en summabild av RGB-bilderna. Detta 
innebär att varje pixel i summabilden räknas fram som summan av motsvarande tre 
pixlar i R-, G- och B-bilderna. Därefter divideras pixel för pixel R-, G- och B-bilderna 
med summabilden. Vid dessa beräkningar måste man se upp med att man inte får för 
låga eller höga pixelvärden, eftersom detta kan ge ”klippning” uppåt eller nedåt beroende 
på att varje pixel ofta bara representeras i datorn av 8 bitar. För att undvika problem med 
detta ska vi i laborationen omvandla bilderna till 16-bitarsrepresentation. Mer om det 
rent praktiska, samt hur färgtriangeln uppritas, beskrivs under rubriken 

Laborationsuppgifter. 
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Laborationsuppgifter 
 

Bildmaterial 
 

Börja med att förflytta er till ”Skrivbordet → Tekn.foto → L7”. Skapa där en mapp med 

er grupps namn. I mappen ”L7” ligger en mapp som heter ”Originalbilder”. Kopiera in 
denna mapp i er nyskapade mapp. Nu har ni inne i er mapp tillgång till alla bilder ni ska 
använda i denna laboration. 
 
 

I. Sampling av testbild 
 
I den första delen av laborationen studeras effekten av olika samplingtätheter. Testbilden 
utgörs av ett svartvitt linjemönster med ortsfrekvensen 1.0 mm-1, och med en 
sinusformig intensitetsprofil, Fig. 3.  

 

 
 

 
 

 

Fig. 3. 
 
Testbilden som vi ska utgå från är originalbilden med filnamnet ”sinustestmönster.tif”. 
Bildens totala storlek svarar mot 50 mm x 40 mm i verkligheten, vilket framgår av 

”etiketten” uppe till vänster i Fig. 3. 
 
Från denna ursprungsbild ska vi skapa digitalbilder som har följande samplingfrekvenser, 
dvs pixeltätheter, uttryckt i sorten mm-1: 

 

0.7 0.9 1.0 1.1 1.5 1.8 2.0 2.2 3.5 

 
För att skapa bilder med ovanstående pixeltätheter ska programmet ImageJ användas. 

Öppna originalbilden med ImageJ: File → Open. Välj sedan: Image → Adjust → Size. 

Välj ”Width (pixels)” till lämpligt värde. (Du har uppgift om önskade pixeltätheter, och 

                                                 
 I etiketten står också (500 x 400), vilket svarar mot antalet pixlar i ursprungsbilden. Detta behöver du inte 
bry dig om – pixelantalet är så stort att du kan betrakta ursprungsbilden som analog. 

Intensitetsprofil längs vita linjen 

Ortsfrekvens = 1.0 mm-1 

50 mm (= 50 perioder) 

40 

mm 
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du vet bildens totala mått, 50 mm x 40 mm. Då kan du räkna ut hur många pixlar bilden 
ska innehålla.). ”Constrain Aspect Ratio” ska vara förbockat, och ”Interpolate” ej 
förbockat. Klicka sedan på OK. Observera att ni alltid måste utgå från originalbilden vid 

skapandet av en ny bild med annan pixeltäthet
*
. 

 

 Tillverka nya bilder med pixeltätheter enligt listan på 
föregående sida, och spara dessa bilder i tif-format under 
lämpliga namn (skriv inte över originalbilden!). 

 
Nästa uppgift blir att mäta upp ortsfrekvensen för linjemöstren i de nya bilderna. Även 
detta görs med ImageJ. Efter att en bild öppnats väljer man linjeredskapet och ritar en 
horisontell linje över bilden (linjen blir perfekt horisontell om man håller nere shift-
tangenten när detta görs). Gör linjen så bred att den täcker åtminstone 10 perioder (gärna 

fler). Genom att sedan välja Analyze → Plot Profile så får man en linjeprofil uppritad på 

skärmen. Genom att flytta cursorn kan man läsa av X-positionen för toppar eller 
dalgångar i kurvan. Om man mäter avståndet över ett antal perioder kan man beräkna 
(medel) ortsfrekvensen. Observera att vissa toppar kan vara lite högre och andra lite lägre 
längs linjeprofilen. Detta beror på att samplingpunkterna hamnar slumpvis på lite olika 
ställen på sinusprofilen. Alla toppar, även de lägre, ska räknas när man bestämmer 
ortsfrekvensen. 
 

 Skapa linjeprofiler med ImageJ såsom beskrivits ovan för de 10 
bilderna med olika pixeltätheter. 

 

 Mät upp ortsfrekvensvärden, uttryckt i mm-1, ur de 10 
linjeprofilerna. 

 

 Använd Datascape för att rita upp de uppmätta 
ortsfrekvensvärdena som funktion av pixeltätheten i bilderna. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

                                                 
* Det kan kännas jobbigt att behöva öppna originalbilden varje gång man vill skapa en bild med annan 
pixeltäthet (originalbilden försvinner i denna process). För att slippa detta kan man duplicera originalbilden 
i tillräckligt antal (10 st) och sedan utföra pixelreduktionen på de duplicerade bilderna. Duplicering görs 

genom “Image → Duplicate” och sedan klicka på OK. 

Visa upp och diskutera resultaten med 

laborationshandledaren innan ni fortsätter! 

Handledaren kan även visa en teoretisk kurva 

över förväntade resultat. 
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Som avslutning på samplinguppgifterna ska vi studera svävningsfenomen. 
 

 Skapa en bild av sinustestmönstret med pixeltätheten 2.1 mm-1. 
 

 Skapa sedan en linjeprofil med ImageJ på samma sätt som 
tidigare. 

 

 Är samplingkriteriet uppfyllt?  Svar: ________________ 
 

 Stämmer ortsfrekvensen i linjeprofilen med originalbildens? 
(Mät över en lång sträcka, typ hela bildbredden, och tänk på att 
alla toppar, även låga, ska räknas.)  Svar: _______________ 

 

 Rita på papper upp en (approximativ) sinusvåg (4-5 perioder är 
lagom), samt markera var samplingpunkterna hamnar om vi 
samplar lika tätt som i fallet ovan (2.1 mm-1). Förklara utgående 
från figuren hur svävningsfenomen uppstår vid sampling. 

 

 Att fundera över: Kan samma typ av svävningsfenomen uppstå 
när man spelar in digital musik, t.ex. på en CD-skiva? En 
musik-CD har samplingfrekvensen 44.1 kHz och fenomenet 
borde kunna inträffa när man samplar toner runt 20 kHz. Varför 
låter inte diskanten i musiken illa?  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Visa upp och diskutera resultaten med 

laborationshandledaren innan ni fortsätter! 
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II. Färganalys av porträttbild. 
 
I detta laborationsmoment ska vi använda en porträttbild i färg, som dessutom innehåller 
en färgskala. Bilden har scannats in från ett småbildsnegativ med samplingtätheten 600 

ppi (pixels per inch


). Den finns lagrad på datorn under filnamnet ” Portrait.tif”. Nu ska 

vi rita upp en färgtriangel med alla bildpixlar inritade. 
 

 Öppna porträttbilden i programmet ImageJ 
 

Ge därefter följande kommandon i ImageJ: 
 

 Plugins → Color Triangle → Before Colocalization. 
 

 Plugins → Color Triangle → Colocalization Finder. 
Image 1 ska vara R.tif (förifyllt) och Image 2 ska vara G.tif 
(förifyllt). Klicka också i ”Also show selected pixels on a 3rd 
grayscale image. Välj här Average.tif. Markera inte ”Restrain ...”. 
Klicka på OK. 

 

Nu dyker 4 nya fönster upp på skärmen. Fönstret ”Correlation Diagram” visar 
färgtriangeln. Fönstret ”Colocalized points” ska vi inte använda, utan minimerar därför 
(stäng inte!). Fönstret ”DIC superposition in Green” visar medelvärdesbilden med en 
grön overlay (vi återkommer strax till detta). Slutligen finns också ett Results-fönster som 
vi också återkommer till i moment III. 
 

Vi ska börja med att titta på färgtriangeln. Denna utgörs av en bild med 256 x 256 pixlar 
som visar samma sak som Fig. 2. Detta innebär att bilden är helt svart (pixelvärde = 0) 
ovanför en diagonal från övre vänstra till nedre högra hörnet. Av datortekniska skäl 
ligger dock r- och g-värdena mellan 0 och 255 istället för mellan 0 och 1 som i ekv. 1. 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 

 

                                                 


 En inch (tum) = 25.4 mm. 

r-värde 

g-värde 

0 
0 

255 

255 102 

85 

Pixelvärde 23 

Fig. 4 
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Vad betyder då pixelvärdena i färgtriangelbilden? Exemplet som visas i Fig. 4 innebär att 

23 pixlar i den ursprungliga färgbilden har normerade färgvärden r = 102 och g = 85, dvs 
precis samma färgton (i detta fall gult med lite dragning åt orange). Om originalbilden 
innehåller stora, homogent färgade ytor, kommer dessa i färgtriangel att representeras av 
ljusa väl avgränsade fläckar. 
 
Vi ska nu identifiera vad de olika fläckarna som syns i färgtriangeln motsvarar för delar i 
originalbilden. När detta görs är det en fördel att också ha den ursprungliga färgbilden 
uppe på skärmen. I färgtriangelbilden finns en gul ruta markerad. Rutans storlek och läge 
kan ändras genom att använda mus plus vänsterknapp. Samtidigt ändras också den gröna 
overlayen på medelvärdesbilden. De pixlar som är grönmarkerade har färgtoner som 
ligger innanför den valda rutan i färgtriangeln. 
 
Gör nedanstående moment utgående från färgtriangelbilden. 
 

 Vi ska nu printa ut en färgtriangelbild på vanligt papper (för att 
rita på). Markera bildramen, därefter File → Print. (Om ni vill 
slippa den svarta bakgrunden kan ni invertera bilden före 
utskrift: Edit → Invert) 

 

 Man kan se ungefär 8 distinkta fläckar i färgtriangeln. Undersök 
vad dessa motsvarar för delar i originalfärgbilden. Skriv in detta 
på pappersbilden. 

 

 På originalbilden finns 6 homogena fält i färgerna rött, grönt, 
blått, gult, magenta och cyan. Hamnar dessa på de ställen i 
färgtriangel som förutspåddes i förberedelseuppgift 3? Om ej, 
förklara varför: 

 

Svar:_____________________________________ 
 

 Förutom de 8 distinkta fläckarna i färgtriangeln, finns även mer 
diffusa och utbredda strukturer. Vad motsvarar dessa i 
originalfärgbilden? Skriv in detta på pappersbilden av 
färgtriangeln! 

 

 På originalfärgbilden finns 6 gråfält infotograferade. Har alla 
dessa samma neutralgråa färgton, eller avviker något/några 
gråfält från de övriga? Vilken färgton har i så fall de avvikande 
fälten? 

 

Svar:___________________________________ 
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 I färgtriangelbilden syns ett knappt tiotal ensamma vita pixlar 
utspridda över en stor yta. Från vilka områden i 
originalfärgbilden härstammar dessa ensamma vita pixlar, och 
varför får vi inte lite större utbredda fläckar i färgtriangeln som 
från andra färgade områden? 

 

Svar:____________________________________ 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Visa upp och diskutera resultaten med 

laborationshandledaren innan ni fortsätter! 
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III. Färganalys av flygbild. 
 
I detta laborationsmoment ska vi använda ett flygfotografi i färg (Aerial.tif). Bilden har 
scannats in från en mellanformatsdiabild (55 mm x 55 mm) med samplingtätheten 400 
pixels per inch. 
 

 Framställ en färgtriangel av flygbilden på samma sätt som 
gjordes för porträttbilden i moment II. 

 

 Undersök vad de ljusa fläckarna i färgtriangeln motsvarar i 
originalfärgbilden. (Skriv ut en pappersbild på samma sätt som 
i moment II, och skriv i vad fläckarna motsvarar.) 

 
I detta laborationsmoment ska vi också använda färgtriangeln för att utvinna kvantitativ 
information om motivet på originalbilden. Detta görs med hjälp av Results-fönstret som 
visas på skärmen samtidigt som färgtriangeln. Detta fönster visar en tabell med 
siffervärden, varav vi här bara ska utnyttja kolumnen längst till höger märkt ”% 
colocalization”. Varje rad i tabellen motsvarar värden från ett gult rektangulärt fönster i 
färgtriangeln. Varje gång man flyttar eller ändrar dimensionerna på fönstret adderas en ny 
rad i Results-fönster med värden för det aktuella fönstret. Vad betyder då värdena i 
kolumnen ”% colocalization”? Jo, om det exempelvis står 35, så innebär det att 35 % av 
pixlarna i originalfärgbilden har en färgton som ligger inom det rektangulära fönstret. 
Man kan alltså med detta redskap direkt se hur stor procentuell andel av alla pixlar som 
har en viss färg. Vi ska nu använda detta för att kvantitativt bestämma arean på olika fält 
etc. som syns på bilden. 
 

 Bestäm hur stor area på marken som är bevuxen med 
blommande gul raps. Data för flygbilden är desamma som 
används i förberedelseuppgift 4. 

 

Area av rapsfält = ____________________________ 
 

 

 Bestäm hur stor area på marken som utgörs av barmark, dvs 
inte är bevuxen med vegetation (åker utan gröda, vägar etc.). 

 

Area av barmark = ____________________________ 
 

 

 Bestäm hur stor area på marken som är bevuxen med grön 
vegetation (ängar, gröna åkrar och skog). 

 

Area av grön vegetation = ________________________ 
 

 

Redovisa resultaten för laborationshandledaren! 
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IV. Vilken pixeltäthet behövs i en papperskopia? 
 
Bilder från digitalkameror, filmscanners och dokumentscanners innehåller oftast många 
miljoner pixlar. Men kan man verkligen se alla dessa på papperskopian? Ja det beror 
naturligtvis på papperskopians storlek, betraktningsavstånd och huruvida man gör 
delförstoringar. I detta lab-moment ska vi experimentellt bestämma vilken pixeltäthet 
som behövs i papperskopian för att man vid ”normal” betraktning inte ska störas av 
pixelleringen. 
 
Ni kommer att få titta på ett antal papperskopior i storlek 10 x 15 cm av samma motiv. 

Det enda som skiljer kopiorna är antalet pixlar per tum. Ni ska titta på kopiorna utan att 
använda något förstorande optiskt hjälpmedel, och bedöma i vilka ni kan se 
pixelleringseffekter (hackighet, speciellt i diagonala kanter). Även om ni inte direkt kan se 
pixelleringseffekter kanske ni får lite olika skärpeintryck av bilderna. 
 
 

Rangordna bilderna A-G kvalitetsmässigt i en skala ”sämst”, ”näst sämst” etc. upp 

till ”bäst” (i vissa fall kanske ni inte ser skillnad på bilderna, och då får dom 

naturligtvis samma kvalitetsbetyg). 
 
 

Rangordning: 
 
 
När ni gjort er bedömning kommer handledaren att informera er om hur många pixlar 
per tum som finns i de olika papperskopiorna. 
 
 
 

 

Slutsats (hur många pixlar behövs i t.ex. en 10 x 15 cm bild?): 

 

 

 

 

 

 

Samma fråga, men för pappersformat A4: 
 

 

 

 

 
 

 

                                                 
 Av gammal hävd används tum (25.4 mm) som längdmått i dessa sammanhang. 
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V. Stereobetraktning av flygbilder (om tid finns). 
 
Genom att kombinera två bilder tagna från lite olika positioner får man ett så kallat 
stereopar. Man kan då uppleva ett äkta djup i bilden som inte är möjligt med en enda bild 
(kap. 9 i kompendiet beskriver principen för stereofotografi). Stereobetraktning är till 
stor hjälp vid tolkning av flygbilder. Detta har använts av militären under t.ex. andra 
världskriget. 
 
Som avslutning av denna laboration får de som så önskar tillfälle att titta på ett par 
stereoflygbilder tagna på IR-färgfilm av det område som utforskades i 
laborationsmoment III. Handledaren kommer att ge närmare anvisningar vid 
laborationstillfället. 
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Förberedelseuppgifter: 
 

 

1. 
 

En dokumentscanner har en maximal samplingtäthet av 1200 ppi (pixels per inch). Klarar 
scannern av att registrera nedanstående periodiska mönster så att ortsfrekvensen återges 
korrekt? 

 

 

 

 

 

 

 

 

2. 
 

 

I figuren ovan visas hur två olika sinuskurvor samplas med 25 enheters mellanrum längs 
x-axeln (streckade linjer markerar samplingpunkter). Trots att kurvorna har olika 
utseende så har de samma värde just i samplingpunkterna. Ur de samplade värdena kan 
man därför inte avgöra vilken av kurvorna man ursprungligen hade. Uppenbarligen 
kräver den tätare kurvan (den med periodlängd 10) att man samplar betydligt tätare om 
man ska få med verkliga utseendet.  

Rita i figuren ovan in vad som händer om man samplar den tätare kurvan (den med 
periodlängd 10) så att samplingpunkterna ligger med ett inbördes avstånd av 4 enheter 
längs x-axeln. Sammanbind samplingpunkterna med räta linjer på samma sätt som är 
gjort i Fig. 38.2 i kompendiet (rita gärna med en glad färg). Liknar det originalfunktionen 
(sinus) till form och periodlängd? Är samplingteoremet uppfyllt? Om så är fallet, varför 
blir inte resultatet bättre? (jfr. Fotokompendiet, kap. 38). 

 

mm 

1.0 0 
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3. 

 

 

 

 

 

 

 

 

 

 

 

 

 
 

 

 

 

 

 

 

 

 

 

 
 
I färgtriangeln ovan är sju områden utmärkta med siffrorna 1-7. Vilka färger motsvarar 
dessa områden? 
 

 

4. 
 

En flygbild (lodbild) fotograferas från 1300 meters höjd med en kamera som har 
brännvidden 75 mm och negativstorleken 55 mm x 55 mm. Efter filmframkallning läses 
negativet in med en filmscanner. Scanner-inläsningen görs med upplösningen 400 ppi. 
Hur stor area på marken motsvarar en pixel i den inlästa digitala bilden? 
 
 
 
 
 
 

b r 

g 

 1. 

 2.  

 3.  4.  5. 

 6. 

 7. 
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Appendix: Plotprogrammet “Datascape” 
 

(Freeware som kan nedladdas från t.ex. http://nilaysoft.sitesled.com/) 
 
 
Programmet startas genom att dubbelklicka på ikonen ”Datascape-plot” på skrivbordet. 
Indata till programmet skrivs in i en textfil (använd programmet ”Notepad” som finns 
som ikon på skrivbordet). På varje rad i textfilen skrivs en plotpunkts x- och y-
koordinater in på formen: 
 
 

x           y 
 

där             står för tab. 
 

OBS!: Efter att sista plotpunkten matats in måste man trycka Return 

så att cursorn matar fram till nästa rad innan man sparar filen 

(annars plottas inte sista värdet). 

 

Datascape använder decimal-punkt, inte komma! 
 
Data för flera kurvor kan sparas i samma fil genom att addera flera y-kordinater på 
samma rad (åtskilda av ”tabbar”). Spara textfilen under lämpligt namn. 
 
För att plotta upp värdena i en fil klickar man på Open-knappen i Datascape-fönstrets 
överkant och väljer önskad datafil. Öppnar man flera datafiler efter varandra så plottas 
samtliga kurvor i samma diagram med olika färger. Är man inte nöjd med programmets 
autoskalning av axlarna (OBS: Autoscale placerar lägsta mätpunkten i origo) kan man 

manuellt sätta skalningen genom att klicka på ”View  Scale” och mata in önskade 
värden. 
 
Man kan även ändra kurvornas färg, strecktjocklek med mera genom att peka på en 
kurva, högerklicka med musen och välja ”Properties”. Även axlarnas utseende, font, 
bakgrundsfärg etc kan väljas genom kommandon som finns under View-knappen i 
fönstrets överkant. 
 

Man kan sätta valfri titel på sin plot genom att klicka på ”Window  Title”, och skriva 
in önskad titel. 
 
Man kan zooma in en del av diagrammet genom att markera ett område med mus plus 
nedtryckt vänsterknapp. När man släpper knappen förstoras området inom rutan upp. 
 
Kurvorna kan skrivas ut genom att klicka på Print. Pappersytan utnyttjas oftast bättre om 

man skriver ut i liggande format (”File  Page Setup  Landscape”). 
 
Även matematiska funktioner kan plottas genom att trycka på gröna Start-knappen i 
fönstrets överkant och därefter skriva in ett matematiskt uttryck. Under Settings (två steg 
till höger om Start-knappen) kan man välja inom vilket intervall matematiska uttrycket 
ska plottas, samt steglängd. Mer information kan hittas under Help/Readme. 
 

http://nilaysoft.sitesled.com/

