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Getting Started Guide 

IAR KickStart Kit™ for STMicroelectronics’ STM32F103ZE 

This guide briefly describes how to get started using IAR Embedded Workbench® with 
IAR J-Link OB (on board) debug interface to run an example application on the 
STM32F103ZE-SK target system.  

For more detailed information, see the IAR Embedded Workbench® IDE User Guide, 
which also contains the C-SPY hardware debugger documentation. This document is 
reached from the Help menu in the IAR Embedded Workbench IDE. 

 

Features of the STM32F103ZE-SK evaluation board 

• STM32F103ZE device   
• Stepper motor  
• 3-axis accelerometer 
• Temperature sensor 
• Buzzer 
• SD/MMC card slot 
• I2S routed to speaker codec 
• DAC one channel routed to pin 
• USB 2.0 full speed connector 
• ADC (routed to potentiometer) 
• I2C (routed to UEXT connector) 
• SPI1 (routed to UEXT) 
• 2 USART DB9 connectors 
• CAN routed to a three-pin terminal block 
• JTAG/SWD interface connector (standard 20-pin) 
• ETM v3 Trace connector (as defined by ARM) 
• J-Link OB (your J-Link for ARM is mounted on the evaluation board) 
• Status LED 
• Power supply LED 
• Reset button 
• External power connector, through J-Link and USB (jumper selectable) 
• Potentiometer (AN-TR) 
• Color LCD 
• 4 User LEDs 
• One user button to simulate external events  
• One wake-up button 
• Joystick 
• Prototype area 
• Jumper for measuring power consumption from the controller 
• RoHS-compliant 
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Install IAR Embedded Workbench for ARM 

1 Insert the IAR KickStart Kit installation CD. The CD contains all the software you need to get 
your project up and running. The installation program starts automatically. 

2 First choose which board you are working with, and then move on to the CHOOSE 
SOFTWARE page. 

3 Select the IAR Embedded Workbench for ARM installation of your choice. We recommend the 
KickStart edition which has no time limit.  

 
Figure 1 - Install software 

4 Follow the installation directions given on the installation CD. You will have to register your 
product to get your license number and key. These will be delivered to you via e-mail within a 
few minutes. After this you will be able to install the software. Note that it can take several 
minutes for the installation files to unpack. 

We recommend that you use the default directories on your installation.  

Setting up the evaluation board  

Before you start IAR Embedded Workbench, IAR J-Link OB (on board) for ARM (hereafter 
called IAR J-Link) must be installed. 

1 Set the following jumpers 

Jumper(s) Description 

PWR_SEL Pin 3-4 closed - power from J-Link OB 
JTAG_SEL Open, J-Link OB is used 

Table 1 - Jumper settings 

2 Connect your computer and the IAR J-Link through the USB connector USB-JLINK, located on 
the top left side beside the stepper motor.  

3 The Power LED on the evaluation board should now be lit. 

4 If this is the first time that you are using J-Link, Windows will start the Install wizard. Choose 
Install from a specific location. 

5 When asked to locate the USB drivers, click the browse button and navigate to the \Program 
Files\IAR Systems\Embedded Workbench x.x Kickstart\arm\drivers\JLink\ 
directory. 

6 Click Finish. IAR J-Link is now installed. 
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Running example applications 

When you have installed and set up all the software and hardware, it is time to try out one of the 
example applications provided with the IAR Embedded Workbench KickStart edition for ARM.  

To take full advantage of the example application, you should have some working knowledge of 
IAR Embedded Workbench IDE. For a quick introduction, see the tutorials in the ARM IAR 
Embedded Workbench® IDE User Guide, available as an online PDF from the IAR Embedded 
Workbench IDE Help menu. 

The example described here is Buzzer which will let you control the buzzer to make a sound by 
pressing the button. 

1 From the Start menu, start the IAR Embedded Workbench IDE by choosing All Programs> 
IAR Systems> IAR Embedded Workbench for ARM x.xx Kickstart >IAR Embedded 
Workbench. You will get straight into the IAR Information Center for ARM. 

2 Click EXAMPLE PROJECTS. 

 
Figure 2 - IAR Information Center for ARM 

3 Select in order ST, STM32F10xx and finally your board IAR-STM32F103ZE-SK. 

4 Select the Buzzer example. 

5 Choose a destination folder to save a copy of this project for testing, so that the original project 
will not be updated for any changes you made during testing. 

6 Read the Example description in the Editor window or the readme.txt file included in the 
project.  
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7 Choose Project>Make or click the Make button on the toolbar. The project should compile with 
no errors (you can ignore the warnings). 

 
Figure 3 - The Make button 

8 Choose Project>Download and Debug or click the Download and Debug button  on the 
toolbar to downloaded your program to the development board.  

9 The file main.c is now open in the editor window and the program is stopped at the start. Click 

Debug>Go or click the Go button  on the toolbar to start the application.  

10 The LCD is showing an IAR Systems logo. Press the TAMPER button; you will hear that the 
buzzer makes a sound.   

11 To stop C-SPY, click the Break button  on the debug bar. 

12 To exit C-SPY, click the Stop Debugging button  on the toolbar. 

In order to try other example projects included click Help>Information Center to bring up the 
IAR Information Center again. Remember to read the project descriptions in each project. 

 

Short comments of the example applications included 

In all example applications, there is an Example descriptions or a readme.txt that gives 
more detailed instructions. Given below are some extra hints. 

Mass Storage and USB Mouse: A separate USB cable is needed to connect your PC and USB-B 
port. 

Stepper Motor Demo: +5v external power might be needed (Pin 7 and 8 should be closed on 
PWR_SEL). 

Virtual COM: After you press the Go button, a separate USB cable is needed to connect your 
PC and USB-B port. You will also be asked to install the Virtual COM driver from  

\Program Files\IAR Systems\Embedded Workbench x.x Kickstart\arm\examples 
\ST\STM32F10x\IAR-STM32F103ZE-SK\VirtualCom\VirCOM_Driver_XP.  

After this you should be able to find IAR Virtual COM port under Device Manager>Ports 
(COM& LPT).  

Test Demo: The code size of this example exceeds the 32K limit. Please download and test on 
the 30-day evaluation edition (http://www.iar.com/downloads). 
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Running IAR PowerPac BSP  

When IAR Embedded Workbench is installed, it will also automatically install an IAR PowerPac 
evaluation edition along with it.  

1 From the IAR Embedded Workbench IDE, choose Project>Add Existing Project and navigate 
to your local copy of the BSP directory, select Start_STM32_HD.ewp and click Open. 

2 Rebuild and run the application (repeat step 7-10 as above), the application will start two periodic 
tasks that blink the LEDs (make sure that the jumpers on STAT1_E and STAT2_E are closed). 

To try other example applications included in the Application/Excluded group. Use drag and 
drop to move the RTOS start application OS_Start_LEDBlink.c from the folder 
Application into the folder Application\Excluded. Then move the example application of 
choice from the folder Excluded into the folder Application, rebuild and run. 

 
Figure 4 - Try other examples by exchanging the active file 
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Hints and troubleshooting 

Change debug interface between JTAG and SWD 

On the STM32 Cortex-M3 device, you can choose between two different debug interfaces – the 
standard JTAG interface or the SWD (serial wire debug) interface. When you have started IAR 
Embedded Workbench for ARM, you can change the debug interface used through the project 
options:  

 
Figure 5 - Choose JTAG or SWD debugger interface 
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Jumper descriptions 

 
 
 
   
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
   

Figure 6 – evaluation board jumpers 

 

BOOT PWR_SEL 

JTAG_SEL 

STATX_E CTS2_E 

RX1_BOOT/RX1 
TX1_BOOT/TX1 

3.3V_MCU_EN 
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Jumper  Description 

PWR_SEL pin 1-2 Power from USB +5VDC 
PWR_SEL pin 3-4 Power from USB J-Link-OB +5VDC (default) 
PWR_SEL pin 5-6 Power from the J-Link probe through the JTAG connector +5VDC 
PWR_SEL pin 7-8 Power from external source +5VDC 

B0_1/B0_0  
Boot select 0 

B0 B1 Description 

0 X Embedded flash (default) 
1 0 System memory 
1 1 Embedded SRAM 

 

B1_1/B0_1 
Boot select 1 
STAT1_E Connect status LED1 (PF6) (default closed) 
STAT2_E Connect status LED1 (PF7) (default closed) 
STAT3_E Connect status LED1 (PF8) (default closed) 
STAT4_E Connect status LED1 (PF9) (default closed) 
CTS2_E Connect UART2 RS232 CTS signal (default open) 

3.3V_MCU_EN 
Connect 3.3V supply to STM32F for current consumption measurement 
(default closed) 

JTAG_SEL Disconnect J-Link on board (default open) 

RX1_BOOT/RX1  
RX1_BOOT connects RS232_1 to PA10 
RX1 connects RS232_1 to PB7 (default) 

TX1_BOOT/TX1 
TX1_BOOT connects RS232_1 to PA9 
TX1 connects RS232_1 to PB 6 (default) 

Table 2 - Jumper settings 

Note: Square pads indicate pin 1.
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Board layout 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 

 

 

 

 

 
Figure 7 – evaluation board connectors 

1The stepper motor needs 700 mA. Supply the board with external power when using it. 
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Input/output 

The USER button is connected to the STM32F103ZE pin 93 (PG8). 

The WKUP button is connected to the STM32F103ZE pin 34 (PA0/WKUP/USART2_CTS/ 

ADC123_IN0/TIM5_CH1/TIM2_CH1_ETR/TIM8_ETR). 

The TAMPER button is connected to the STM32F103ZE pin 7 (PC13/TAMPER-RTC). 

The RESET button is connected to the STM32F103ZE pin 25 (NRST). 

The joystick J1’s right is connected to the STM32F103ZE pin 92 (PG7/FSMC_INT3). 

The joystick J1’s left is connected to the STM32F103ZE pin 127 (PG12/FSMC_NE4). 

The joystick J1’s down is connected to the STM32F103ZE pin 128 (PG13/FSMC_A24). 

The joystick J1’s up is connected to the STM32F103ZE pin 129 (PG14/FSMC_A25). 

The joystick J1’s center button is connected to the STM32F103ZE pin 132 (PG15). 

A power-on PWR LED shows that the board is powered on. 

The STAT 1 LED is connected to the STM32F103ZE pin 18 (PF6/ADC3_IN4/FSMC_N/ORD). 

The STAT 2 LED is connected to the STM32F103ZE pin 19 (PF7/ADC3_IN5/FSMC_N/REG). 

The STAT 3 LED is connected to the STM32F103ZE pin 20 (PF8/ADC3_IN6/FSMC_N/OWR). 

The STAT 4 LED is connected to the STM32F103ZE pin 21 (PF9/ADC3_IN7/FSMC_CD). 

The LED by the name LED indicates the JTAG status. 

The USB_C LED indicates that information is sent over USB. 

A trimpot AN_TR is connected to the STM32F103ZE pin 44 (PC4/ADC12_IN14). 

A color LCD display with a resolution of 132x132 pixels. 
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Prototyping area 

The prototyping area permits adding of new components. 

 
Figure 8 - Pins connected to the prototyping area 

 
Clock circuit 

The oscillator Q1 at 8 MHz is connected to the STM32F103ZE OSC_IN pin and the OSC_OUT 
pin. 

The oscillator Q2 at 32.768 kHz is connected to the STM32F103ZE PC14/OSC32_IN pin and the 
PC15/OSC32_OUT pin. 
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External connectors description 

JTAG 

 
Pin # Signal name Pin # Signal name 

1 +3.3V 2 +3.3V 
3 TRST 4 GND 
5 TDI 6 GND 
7 TMS 8 GND 
9 TCK 10 GND 
11 RTCK 12 GND 
13 TDO 14 GND 
15 RST 16 GND 
17 GND 18 GND 
19 +5V_JLINK 20 GND 

 

TDI Input Test Data In. This is the serial data input for the shift register. 

TDO Output Test Data Out. This is the serial data output for the shift register. Data is shifted out 
of the device on the negative edge of the TCK signal. 

TMS Input Test Mode Select. The TMS pin selects the next state in the TAP state machine. 

TCK Input Test Clock. This allows shifting of the data in, on the TMS and TDI pins. It is a 
positive edge triggered clock with the TMS and TCK signals that define the internal state of the 
device. 

TRST Input Test Reset. This signal resets the JTAG controller. 

RTCK Output Return Clock. This is a synchronization signal which the JTAG connector uses to 
acknowledge that it is ready to receive/transmit. 

JTAG is used for programming and debugging the MCU. 



 
 

GS-STM32F103ZE-5  13 

RS232_1 
Pin # Signal name 

1 NC 
2 TIM1_CH2/TX1 or USART1_TX 
3 TIM1_CH3/RX1 or USART1_RX 
4 NC 
5 GND 
6 NC 
7 NC 
8 NC 
9 NC 

 

RS232_2 
 
 
 

 

 

 

 

 

UEXT 
 

Pin # Signal name 

1 NC 
2 USART2_TX 
3 USART2_RX 
4 NC 
5 GND 
6 NC 
7 CTS 
8 RTS 
9 NC 

Pin # Signal name Pin # Signal name 

1 VCC 2 GND 
3 USART1_TX 4 USART1_RX 
5 I2C2_SCL 6 I2C2_SDA 
7 SPI1_MISO 8 SPI1_MOSI 
9 SPI1_SCK 10 CS_UEXT 
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SD/MMC card slot 

 
 

Pin # Signal name Pin # Signal name 

1 SD_D3 2 SD_CMD 
3 GND (VSS1) 4 VDD 
5 SD_CLK 6 GND (VSS2) 
7 SD_D0 8 SD_D1 
9 SD_D2 10 WP_E 
11 NC 12 NC 
13 CP_E 14 3.3V 
15 3.3V   

 

SD_D0-3 I/O Memory Card Interface Data 0-4. These are the data lines for the SD/MMC 
connector. They could be both input and output for the MCU depending on the data flow 
direction. 

SD_CMD Output Memory Card Interface Command. This is a command sent form the 
processor to the memory card and as such it is output from the processor. 

SD_CLK Output Memory Card Interface Clock. This signal is output from the MCU and 
synchronizes the data transfer between the memory card and the MCU. 

WP_E Input Write Protect. This signal is input for the MCU. 

CP_E Input Card Present. This signal is input for the MCU. 

 

CAN 
 
 

 

 

Pin # Signal name 

1 CANH 
2 CANL 
3 GND 
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Audio Out 
 
 
 
 
 

LEFT Output Left channel output. 

GBUF Output Virtual ground for audio output. 

RIGHT Output Right channel output. 

 

 

PWD 

 

 

The power input should be +5 VDC, 500 mA (700 mA when the stepper motor is used). 

 

VBAT 
 

 

 

The RTC (real-time clock) and backup registers can be powered by VBAT. 

The voltage should be 1.8 to 3.6 V. 

Pin # Signal name 
1 LEFT 
2 GBUF 
3 RIGHT 

Pin # Signal name 

1 Power input 
2 GND 

Pin # Signal name 

1 + 
2 - 
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Trace 

 
 

 

 

 

 

 

 

 

Pin # Signal Description Pin # Signal Description 

1 VCC 3.3V 2 TMS  
3 GND  4 TCK  
5 GND  6 TDO  
7 NC  8 TDI  
9 GND  10 RST  
11 GND  12 A23  
13 GND  14 A19/TDO Depends on R156/R157 
15 GND  16 A20/TRST Depends on R160/R161 
17 GND  18 A21  
19 GND  20 A22  
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ADDR_MOTHER 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

Pin # Signal Description Pin # Signal Description 

1 A0  2 VCC  
3 A1  4 VCC  
5 A2  6 VCC  
7 A3  8 VCC  
9 A4  10 VCC  
11 A5  12 GND  
13 A6  14 GND  
15 A7  16 GND  
17 A8  18 GND  
19 A9  20 DOWN  
21 A10  22 DISC  
23 A11  24 NE3  
25 A12  26 NE2  
27 A13  28 NE1  
29 A14  30 LEFT  
31 A15  32 RIGHT  
33 NC  34 A23  
35 NC  36 A22  
37 NC  38 A21  
39 A19  40 A20  
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DATA_MOTHER 

 

 

 

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 

 

 

 

Pin # Signal Description Pin # Signal Description 
1 D0  2 VCC  
3 D1  4 VCC  
5 D2  6 VCC  
7 D3  8 VCC  
9 D4  10 VCC  
11 D5  12 GND  
13 D6  14 GND  
15 D7  16 GND  
17 D8  18 GND  
19 D9  20 GND  
21 D10  22 CP  
23 D11  24 CNTRL  
25 D12  26 CPLD_INT  
27 D13  28 NC  
29 D14  30 NC  
31 D15  32 NC  
33 /OE  34 STAT2  
35 NC  36 STAT1  
37 /BHE  38 UP  
39 /BLE  40 TEMP_ALERT  
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CAMERA 

 
 
Pin # Signal Description Pin # Signal Description 

1 D0  2 GND  
3 D1  4 GND  
5 D2  6 GND  
7 D3  8 GND  
9 D4  10 GND  
11 D5  12 GND  
13 D6  14 GND  
15 D7  16 GND  
17 A0  18 GND  
19 A1  20 GND  
21 A2  22 GND  
23 /OE  24 GND  
25 /WE  26 GND  
27 NE2  28 VCC  
29 NC  30 VCC  
31 CPLD_RST  32 VCC  
33 CPLD_INT  34 VCC  
35 I2C2_SCL  36 VCC  
37 I2C2_SDA  38 VCC  
39 MCO  40 VCC  
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Troubleshooting 

If you are unable to find the cause of a problem, try resetting the evaluation board by using the 
reset button on the board. Then restart the C-SPY Debugger in the IAR Embedded Workbench 
IDE. You can also try disconnecting and reconnecting the power to the evaluation board, pressing 
the reset button and then restarting C-SPY. 

Disclaimer 

Information given in this document is intended as a help for the user. IAR Systems shall not be 
held liable for any losses or problems arising from using the information given in this document.  

IAR KickStart Kit content Trademarks etc. 

• Welcome letter 

• Installation CD 

• STM32F103ZE-SK evaluation board 

• USB A-B cable 
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