INTRODUCTION TO A FINITE ELEMENT ANALYSIS PROGRAM:

ANSYS
Table of contents

Introduction .................................................................................................................... 3
Short history ................................................................................................................... 3
Basic program structure ................................................................................................. 3
  Preprocessor ........................................................................................................... 5
  Solution processor ................................................................................................. 5
  Postprocessor ........................................................................................................ 6
Tutorial 1: Truss problem .............................................................................................. 7
  Geometry .................................................................................................................... 8
  Material .................................................................................................................... 10
  Element type ........................................................................................................... 11
  Mesh ......................................................................................................................... 12
  Loads ........................................................................................................................ 13
  Solution .................................................................................................................... 14
  Results ...................................................................................................................... 14
Tutorial 2: Beam problem ............................................................................................ 17
  Geometry .................................................................................................................. 17
  Material .................................................................................................................... 17
  Element type ........................................................................................................... 18
  Mesh ........................................................................................................................ 19
  Loads ........................................................................................................................ 19
  Solution .................................................................................................................... 20
  Results ...................................................................................................................... 20
Introduction

The following pages should give you a brief and basic introduction to the architecture and structure of a commercial finite element analysis program. The basic ideas can be applied in most programs but examples are taken from the software ANSYS (version 14, modified from older versions). Here we will only focus on structural mechanics in ANSYS. Note also that many steps can be done in several other ways than what is presented here.

Short history

The usage of the Finite Element Method as a tool to solve engineering problems commercially in industrial applications is quite new. It was used in the late 1950’s and early 60’s, but not in the same way as it is today. The calculations were, at that time, carried out by hand and the method was force based, not displacement based as we use it today. In the mid 60’s, very specialized computer programs were used to perform the analysis. The 1970’s was the time when commercial programs started to emerge. At first, FEM was limited to expensive mainframe computers owned by the aeronautics, automotive, defense and nuclear industries. However, in the late 70’s more companies started to use the FEM, and since then, the usage has grown very rapidly.

Today commercial programs are large and very powerful, complex problems can be solved by one person on a PC. Many of them have the ability to handle different kinds of physical phenomena such as thermo mechanics, electro mechanics and structural mechanics. One often talks about multiphysics, where different kinds of physical phenomena are coupled in the same analysis. There are many available commercial programs, ABAQUS, FLUENT, Comsol Multiphysics, and ANSYS are just a few examples. A full license of a finite element analysis program usually cost on the order of several tens of thousands of Euros. ANSYS is a widely used commercial general-purpose finite element analysis program.

Basic program structure

Treatment of engineering problems generally contains three main parts: create a model, solve the problem, analyze the results. ANSYS, like many other FE-programs, is also divided into three main parts (processors) which are called preprocessor, solution processor, postprocessor. Other software may contain only the preprocessing part or only the postprocessing part. During the analysis you will communicate with ANSYS via a Graphical User Interface (GUI), which is described below and seen in Figure 1.
1. **Utility menu**: Here you can access and adjust properties of your session, such as file controls, listing and graphic controls.

2. **Toolbar**: Buttons for commonly used commands.

3. **Main menu**: Here you can find the processors used when analysing your problem.

4. **Graphics window**: In the graphics window your model is displayed: geometry, elements, visualisation of results and so forth.

5. **Input window**: You can type commands in the input window.

Figure 1: The ANSYS Graphical User Interface (GUI).
Preprocessor

Within the preprocessor the model is set up. It usually includes a number of steps in the following order:

- **Build geometry.** Depending on whether the problem geometry is one, two or three dimensional, the geometry consists of creating lines, areas or volumes. These geometries can then, if necessary, be used to create other geometries by the use of boolean operations. The key idea when building the geometry like this is to simplify the generation of the element mesh. Hence, this step is optional but most often used. Nodes and elements can however be created from coordinates only.
- **Define materials.** A material is defined by its material constants. Every element has to be assigned a particular material.
- **Generate element mesh.** The problem is discretized with nodal points. The nodes are connected to form finite elements, which together form the material volume. Depending on the problem and the assumptions that are made, the element type has to be determined. Common element types are truss, beam, plate, shell and solid elements. Each element type may contain several subtypes, e.g. 2D 4-noded solid, 3D 20-noded solid elements. Therefore, care has to be taken when the element type is chosen.

The element mesh can in ANSYS be created in several ways. The most common way is that it is automatically created, however more or less controlled. For example you can specify a certain number of elements in a specific area, or you can force the mesh generator to maintain a specific element size within an area. Certain element shapes or sizes are not recommended and if these limits are violated, a warning will be generated in ANSYS. It is up to the user to create a mesh which is able to generate results with a sufficient degree of accuracy.

Solution processor

Here you solve the problem by gathering all specified information about the problem:

- **Apply loads:** Boundary conditions are usually applied on nodes or elements. The prescribed quantity can for example be force, traction, displacement, moment, rotation. The loads may also be edited from the preprocessor in ANSYS.
- **Obtain solution:** The solution to the problem can be obtained if the whole problem is defined.
Postprocessor

Within this part of the analysis you can for example:

- **Visualize the results**: For example, plot the deformed shape of the geometry or stresses.
- **List the results**: It is possible to list the results as tabular listings or file printouts.
Tutorial 1: Truss problem

You will now use ANSYS to analyze your first problem. It is taken to be the simple truss problem shown in Figure 2. The truss is fixed in the left wall and the load of 10 000 N is equally distributed on the two upper right joints. It is made of wood with Young’s modulus 16 GPa (parallel to fibers) and cross sectional area 25 cm$^2$. It is recommended that you use SI-units for all quantities in order to obtain a result in SI-units. Saving your model is optional but recommended.

Figure 2: A balcony truss.

To analyze this problem we will go through the following steps:

1. define the geometry
2. define the material
3. choose element type
4. create mesh
5. apply loads and define boundary conditions
6. solve the problem
7. process the results

Start Mechanical APDL (ANSYS). Your model can be saved in a database by specifying your working directory (the folder where you want your ANSYS files to be saved) and a job name (every problem has a job name, for example, truss).

ANSYS Utility menu: File → Change directory …

ANSYS Utility menu: File → Change jobname …
System of units

One has to make sure, that ANSYS is using a proper system of units. The International system (SI) is not necessary set by default. In order to set the system of units to SI, one has to type in the Input window (cf. Figure 1): /UNITS,SI

One can also check, which system of units is being used by typing in the Input window: /STATUS,UNITS
Please refer to ANSYS help (search for /UNITS command) to get more information on available systems of units and ways to create a custom system.

Geometry

We will now draw the structure shown in Figure 2 by first defining keypoints and then drawing lines between them. A visible working plane often makes the creation of the geometry easier. Therefore:

ANSYS Utility menu: WorkPlane → WP Settings …

The dialog box illustrated in Figure 3 will appear. Change to “Grid and Triad” (triad meaning a triplet of base vectors) and set the minimum and maximum to 0 and 2 respectively, OK.

![Figure 3: The WP Settings dialog box.](image)

To display the workplane in the Graphics window:

ANSYS Utility menu: WorkPlane → Display Working Plane
We will now define keypoints at the joints of the truss, see 0 for the location of the keypoints.

ANSYS Main menu: Preprocessor → Modeling → Create → Keypoints → In Active CS

Alternatively type in the input window: K, NPT, X, Y, Z
(you can find the meaning of parameters NPT, X, Y, Z in Figure 4.)

Press Apply to create the first four keypoints. Press OK to create the last keypoint and close the dialog box.

<table>
<thead>
<tr>
<th>Keypoint</th>
<th>x</th>
<th>y</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>2</td>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>3</td>
<td>1</td>
<td>0</td>
</tr>
<tr>
<td>4</td>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>5</td>
<td>2</td>
<td>1</td>
</tr>
</tbody>
</table>

Figure 4: Keypoint coordinates and input dialog box. Z can be set to zero or left blank since the problem is two dimensional.

We will now create lines between the keypoints, see Figure 5.

ANSYS Main menu: Preprocessor → Modeling → Create → Lines → Lines → Straight Line

Alternatively type in the input window: L, P1, P2 (P1, P2 - keypoint numbers)

To create a line between two keypoints type the first keypoint number in the textbox, then press apply. A yellow square will appear, centered around the keypoint, in the workplane. Now type the number of the second keypoint in the textbox and press apply. A line, connecting the two selected keypoints in the workplane, is created. Follow the same procedure to create the remaining four lines. Press OK to create the last line and close the dialog box. To start over, right click on the WP and select replot.

Tip: there is no Undo option in ANSYS. You can delete any geometrical entity by using

ANSYS Main menu: Preprocessor → Modeling → Delete → (choose appropriate)
Figure 5: Lines and keypoints.

**Tip:** You can check your geometry in the graphics display:

ANSYS Utility menu: **Plot → Keypoints → Keypoints**

or

ANSYS Utility menu: **Plot → Lines**

(Alternatively type **KPLOT** or **LPLOT** in the input window)

Numbering of lines and keypoints on the graphics display can be turned on and off in the dialog box after selecting

ANSYS Utility menu: **PlotCtrls → Numbering…**

Alternatively type in the input window: **/PNUM, Label, Key**

where **Label** can be **KP, LINE** and many others and **Key** is 1 (“on”) or 0 (“off”).

**Material**

We assume that the wood behaves linearly elastic. Define the: material model (that is the properties of the material), and the material constants (Young’s modulus, and Poisson’s ratio), see Figure 6:

ANSYS Main menu: **Preprocessor → Material Props → Material Models**
Enter 16e9 for Ex (Young’s modulus) and 0.3 for PRXY (Poisson’s ratio). Press OK, and close the dialog box.

Save your database:

**ANSYS Toolbar: SAVE_DB**

**Element type**

The element type to use is called **link180** (3D finit stn 180). Add this element from the library:

ANSYS Main menu: **Preprocessor → Element type → Add/Edit/Delete → Add…**

or type in Input window: **ET, ITYPE**

(where **ITYPE** is the element type reference number)

A new dialog box has now appeared as shown in Figure 8. Here you can see that the element type link 1 is specified. In this tutorial link 1 is the only element type to be used; however, in more complex structures several different element types could be defined following the same procedure. These elements would also appear in the element types dialog box. Close the dialog box.
The cross sectional area of the elements in the truss structure also has to be defined. This is accomplished with a so-called real constant set:

ANSYS Main menu: **Preprocessor → Real Constants → Add/Edit/Delete**

**Press add in the resulting dialog box.** Choose the element type link1, OK. Fill in the value of the cross sectional area in the box (Note: use SI-units, i.e. m$^2$), OK. In case we would like to define different cross sectional areas for the same element type, multiple real constant sets would be required.

**Mesh**

In this step we will discretize our geometry by creating an element mesh

ANSYS Main menu: **Preprocessor → Meshing → MeshTool**

This opens the MeshTool dialog box. Under **Element Attributes** Select **Lines**, click **Set**. In the dialog box that appears, select the lines which should be associated with your real constant set number. In this case, **Pick all**. Now the dialog box shown in 0 will appear. Check that the material number, real constant set number, and element type number are the ones that you have defined, OK.
Figure 9. Line elements attributes.

We want each line to be divided into one element only. This is accomplished in the MeshTool dialog box under *Size Controls, Lines*, click *Set*. Select *Pick all* in the dialog box that appears. Specify *NDIV* to 1 in the new dialog box, click OK. This step is very important in order to avoid creating a mechanism.

Then click *Mesh* on the meshtool, *Pick all*. Elements and nodes will now be created on the lines.

**Tip:** Element and node numbering and display can be activated similarly to keypoints and lines. Do this to check your elements and nodes.

**Loads**

The displacement is prescribed to zero at the two joints to the left:

ANSYS Main menu: *Solution → Define Loads → Apply → Structural → Displacement → On Nodes*

Click on the appropriate nodes, OK.
Select uₓ and uᵧ and set the value to 0, OK.

The force is prescribed at the two outer joints:

ANSYS Main menu: *Solution → Define Loads → Apply → Structural → Force/Moment → On Nodes*

Choose the y-direction and the value −5000 (the minus sign indicates that the force is directed in the negative y-direction), OK. Two red vectors pointing in the negative y direction, originating at the two outer joints, will appear in the WP.
**Solution**

The problem is now defined and ready to be solved:

ANSYS Main menu: **Solution → Solve → Current LS**

Save your database:

ANSYS Toolbar: **SAVE_DB**

**Results**

Enter the postprocessor and read in the results:

ANSYS Main menu: **General Postproc → Read Results → First Set**

Now there are several results to study. We begin with the displacements:

ANSYS Main menu: **General Postproc → Plot Results → Deformed Shape**

The undeformed and deformed shape should be similar to what is shown in 0.

![Figure 10: Undeformed and deformed mesh.](image)

We can also choose to list the displacements:

ANSYS Utility menu: **List → Results → Nodal solution …**

In the dialog box select Nodal solution, DOF solution and X-displacement components, click Apply. If the previous task is performed correctly, two windows will appear on the screen. These windows will show the selected displacements at the selected nodes. Repeat for Y-displacement components.
Next, axial forces may be of interest. For the current element type, the axial force is stored in a variable called SMISC, 1. We can choose to list them:

ANSYS Main menu: **General Postproc → Element Table → Define Table… → Add…**

Write your own label (force), select Results data item: By sequence num – SMISC, add the item number 1, see Figure 11.
Figure 11: Define element table item.

ANSYS Main menu: General Postproc → Element Table → List Element Table...

Select your data item from the list, OK.

Reaction forces can directly be obtained from the list menu:

ANSYS Utility menu: List → Results → Reaction solution ...

Save everything and you are ready for the next tutorial.
Tutorial 2: Beam problem

In this second tutorial you will analyze a simple problem where beam type elements will be used. The structure to be analyzed is shown in 0. The material is aluminum with Young’s modulus 70 GPa and Poisson’s ratio 0.3. The beam has a rectangular cross-section with the height 6 cm and the area 24 cm². It is recommended that you use SI-units for all quantities in order to obtain a result in SI-units.

![Figure 12: A beam structure.](image)

Follow the general steps outlined in the previous tutorial in solving this problem. If you continue after the previous tutorial you should start a new job:

**ANSYS Utility menu: File → Clear & Start New**

**Geometry**

Just as in the previous tutorial, define keypoints in the current coordinate system. In our current problem the three keypoints can be chosen as (0,0), (1,0) and (1,-1). Once you are done with the keypoints create the two lines between these.

**Material**

Define the material model and the material constants according to the description in the previous tutorial.
Element type

The element type to use is called beam188. Add this element from the library:

ANSYS Main menu: Preprocessor → Element type → Add/Edit/Delete → Add…

To add beam188 select Beam and 2D node 188 in the dialog box as shown in Figure 13. Ok.

![Figure 13: Select element type.](image)

The cross sectional area, shape of the beams also need to be specified. To do this, we use Section under Preprocessor:

ANSYS Main menu: Preprocessor → Sections → Beam → Common Sections…

After you choose that option, a dialog box, as figure 14, will show up. Then you can choose the shape and size of the beam element cross section.

![Figure 14 Common beam section definition.](image)

NOTE: You have to make sure the coordinate orientation of beam section is correctly defined. You can use ‘Preview’ in figure 14 to check whether your section’s coordinate is correct. When you press ‘Preview’, you can see a dialog box appear as figure 15 shows. The default coordinate in this view is marked in red as in figure 15. Therefore, in this problem, B should be 0.04 and H should be 0.06 (Note: use SI-units, i.e. m²).
Figure 15 Preview of section

**Mesh**

You are now ready to create the element mesh, follow the steps outlined in the previous tutorial. Here you can choose to mesh each line with one or more elements (set NDIV).

**Loads**

Since the left end of the beam is clamped, all displacement components and the rotation are prescribed to zero at the corresponding node (0,0):

ANSYS Main menu: **Solution → Define Loads → Apply → Structural → Displacement → On Nodes**

Click on the appropriate node, OK. Select *All DOF* and set the value to 0, OK.

Apply the force 5000 in the x direction on the node at (1,-1), follow the steps in the previous tutorial.

Now we will apply the moment at the coordinate (1,0):

ANSYS Main menu: **Solution → Define Loads → Apply → Structural → Force/Moment → On Nodes**
Click on the appropriate node, OK. Choose $M_z$ and the value 7000, OK. A small cross will appear on the node to indicate the applied moment.

Finally we will apply the pressure on the top beam. Choose

ANSYS Main menu: **Solution → Define Loads → Apply → Structural → Pressure → On Beams**

Select the appropriate line, OK. In the dialog box that appears enter 10000 for $VALI$ and click OK. Note that you can specify a linearly distributed load by entering a value for $VALJ$, which is the value at the other (right) end of the line. As our load is uniform that field should be left blank.

Then you need to define the pressure direction by type in load key (LKEY) value. Here is the load key information:

- **LKEY =1** means pressure is added on xy-plane
- **LKEY =2** means pressure is added on xz-plane
- **LKEY =3** means pressure is added on yz-plane

So if you did not change the default coordinate system, then LKEY should be 2 in this problem.

When finished, the uniform load will show up on the horizontal element.

**Solution**

The problem is now defined and ready to be solved:

ANSYS Main menu: **Solution → Solve → Current LS**

**Results**

Enter the postprocessor and read in the results:

ANSYS Main menu: **General Postproc → Read Results → First Set**

Now there are several results to study. Plot the deformed and undeformed shapes, this has been described earlier.

Next, axial forces may be of interest. We can choose to list them:

ANSYS Main menu: **General Postproc → Element Table → Define Table... → Add...**

Write your own label (force), select Results data item: By sequence num – SMISC, 1.

Add results for the moment by repeating the above steps and add the data items SMISC, 6 and SMISC, 12. For the current element type these variables define the bending moment at the left and right end of the element, respectively.
These items can be studied by listing them

ANSYS Main menu: **General Postproc → Element Table → List Element Table…**

Select your data item from the list, OK.

It is also possible to plot the moment distribution for the beams:

ANSYS Main menu: **General Postproc → Plot Results → Contour Plot → Line Elem Res**

Select SMIS6 for “LabI” and SMIS12 for “LabJ”, OK.

Nodal solutions can be listed as outlined previously. In addition to x- and y-displacements we may also list the z-component of rotation:

ANSYS Utility menu: **List → Results → Reaction solution …**